iOS 14.1 Kernel Vulnerability Could Pave the Way for iOS 14



iOS 14.3 on iPhone 12

Renowned security researcher Ian Beer, known in the jailbreak community for dropping iOS exploits, has shared a kernel vulnerability that affects iOS 14.1 and iPadOS 14.1 and below.

This is the first security exploit that Ian Beer has shared for any release of iOS 14. The details of the security exploit have also been published on the Project Zero Blog. As per the explanation, the vulnerability allows an application to run arbitrary code with elevated kernel privileges on an iPhone or iPad.

Many of Ian Beer’s previous work has led to a jailbreak tool being available for the latest release of iOS. However, before you get your hopes up, Ian Beer has currently only shared a vulnerability in iOS 14. This vulnerability needs to be turned into an exploit before a developer could use it to jailbreak iOS 14 – iOS 14.1. That’s a lot of work and it remains to be seen which developer or jailbreak team puts the effort into jailbreaking iOS 14 and iPadOS 14.

Another issue with the vulnerability is that it won’t work on iPhone XS and newer iOS devices that feature PAC (Pointer Authentication Codes) so even if someone does all the hard work of using this vulnerability to build an iOS 14 – iOS 14.2 jailbreak, it will only work on a limited set of older iPhones. And irrespective of all this, remember that this vulnerability only affects iOS 14.1 and iPadOS 14.1 while Apple has already released iOS 14.4 to the public, with iOS 14.5 coming next month.

As things stand right now, the only way to jailbreak iOS 14 – iOS 14.3 is to use Checkra1n jailbreak but it only supports some older devices like the iPhone 6s, iPhone 7, and iPhone 8.

Are you eagerly looking forward to an iOS 14 – iOS 14.4 jailbreak? Or have you given up on jailbreaking completely? Drop a comment and let us know!



Source link

Leave a Reply